Returns a transformed copy of the geometry in this element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public GeometryElement GetTransformed( Transform transform ) |
Visual Basic |
---|
Public Function GetTransformed ( _ transform As Transform _ ) As GeometryElement |
Visual C++ |
---|
public: GeometryElement^ GetTransformed( Transform^ transform ) |
Parameters
- transform
- Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal |