Creates a new curve loop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static CurveLoop Create( IList<Curve> curves ) |
Visual Basic |
---|
Public Shared Function Create ( _ curves As IList(Of Curve) _ ) As CurveLoop |
Visual C++ |
---|
public: static CurveLoop^ Create( IList<Curve^>^ curves ) |
Parameters
- curves
- Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The curves.
Return Value
The curve loop.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |