Implement this to test whether a particular server should be executed.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
bool CanExecute( IExternalServer server, Document document, IExternalData data ) |
Visual Basic |
---|
Function CanExecute ( _ server As IExternalServer, _ document As Document, _ data As IExternalData _ ) As Boolean |
Visual C++ |
---|
bool CanExecute( IExternalServer^ server, Document^ document, IExternalData^ data ) |
Parameters
- server
- Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be tested.
- document
- Type: Autodesk.Revit.DB..::..Document
The associated document. It may be NULL if not applicable.
- data
- Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated service data. It is the same data the Execute method would receive.