Creates a polyline with coordinate points provided.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static PolyLine Create( IList<XYZ> coordinates ) |
Visual Basic |
---|
Public Shared Function Create ( _ coordinates As IList(Of XYZ) _ ) As PolyLine |
Visual C++ |
---|
public: static PolyLine^ Create( IList<XYZ^>^ coordinates ) |
Parameters
- coordinates
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the count of coordinates is less than 2. |