Returns the profile (not including generated fillets) that defines the shape of the Fabric Sheet bending.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2016

Syntax

C#
public CurveLoop GetBendProfile()
Visual Basic
Public Function GetBendProfile As CurveLoop
Visual C++
public:
CurveLoop^ GetBendProfile()

Return Value

The profile that defines the shape of the fabric sheet bending for bent fabric sheet, for flat fabric sheet nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Remarks

The returned profile defines the center-curve of a wire. Note that bent Fabric Sheets can have planar geometry, but flat Fabric Sheets are always planar.

Examples

CopyC#
#region Autodesk.Revit.DB.Structure.FabricSheet.SetBendProfile(Autodesk.Revit.DB.CurveLoop)
private void ModifyBentFabricSheet(Document document, FabricSheet bentFabricSheet)
{
    CurveLoop newBendingProfile = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, new XYZ(0, 0, -1));
    bentFabricSheet.SetBendProfile(newBendingProfile);

    // Give the user some information
    TaskDialog.Show("Revit", string.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.IntegerValue));
}
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.Structure.FabricSheet.SetBendProfile(Autodesk.Revit.DB.CurveLoop)"
        Private Sub ModifyBentFabricSheet(document As Document, bentFabricSheet As FabricSheet)
            Dim newBendingProfile As CurveLoop = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, New XYZ(0, 0, -1))
            bentFabricSheet.SetBendProfile(newBendingProfile)

            ' Give the user some information
            TaskDialog.Show("Revit", String.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.IntegerValue))
        End Sub
#End Region

See Also