Validates whether the specified element id is a material element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool IsMaterialOrValidDefault(
Element pElem,
ElementId materialId
) |
Visual Basic |
---|
Public Shared Function IsMaterialOrValidDefault ( _
pElem As Element, _
materialId As ElementId _
) As Boolean |
Visual C++ |
---|
public:
static bool IsMaterialOrValidDefault(
Element^ pElem,
ElementId^ materialId
) |
Return Value
True if the element a material element or invalidElementId, which means take material from category, false otherwise.
Exceptions
See Also