Returns an array containing the shared parameter GUIDs that were changed since the last regeneration. Array is empty if no shared params were changed since the last regeneration.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2020

Syntax

C#
public IList<Guid> GetChangedSharedParameterGUIDs()
Visual Basic
Public Function GetChangedSharedParameterGUIDs As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetChangedSharedParameterGUIDs()

Return Value

Returns an array containing the elementId of the shared params that were changed since the last regeneration.

See Also