Returns the list start number of the paragraphs in a given text range.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public int GetListStartNumber( TextRange textRange ) |
Visual Basic |
---|
Public Function GetListStartNumber ( _ textRange As TextRange _ ) As Integer |
Visual C++ |
---|
public: int GetListStartNumber( TextRange^ textRange ) |
Parameters
- textRange
- Type: Autodesk.Revit.DB..::..TextRange
The given text range.
Return Value
The list start number of the text range.
Remarks
Returns -1 if there is a mix of list start values in the range or
if there are paragraphs in different lists or sub-lists in the range or
if there are paragraphs of type None or Bullet in the range.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |