Move a profile of the form, specified by a reference, and an offset vector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void MoveProfile(
int profileIndex,
XYZ offset
) |
Visual Basic |
---|
Public Sub MoveProfile ( _
profileIndex As Integer, _
offset As XYZ _
) |
Visual C++ |
---|
public:
void MoveProfile(
int profileIndex,
XYZ^ offset
) |
Parameters
- profileIndex
- Type: System..::..Int32
Index to specify the profile.
- offset
- Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.
Examples
CopyC#
public void MoveForm(Form form)
{
int profileCount = form.ProfileCount;
if (form.ProfileCount > 0)
{
int profileIndex = 0;
if (form.CanManipulateProfile(profileIndex))
{
XYZ offset = new XYZ(-25, 0, 0);
form.MoveProfile(profileIndex, offset);
}
}
}
CopyVB.NET
Public Sub MoveForm(form As Form)
Dim profileCount As Integer = form.ProfileCount
If form.ProfileCount > 0 Then
Dim profileIndex As Integer = 0
If form.CanManipulateProfile(profileIndex) Then
Dim offset As New XYZ(-25, 0, 0)
form.MoveProfile(profileIndex, offset)
End If
End If
End Sub
See Also