Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public RoutingPreferenceRule(
ElementId MEPPartId,
string description
) |
Visual Basic |
---|
Public Sub New ( _
MEPPartId As ElementId, _
description As String _
) |
Visual C++ |
---|
public:
RoutingPreferenceRule(
ElementId^ MEPPartId,
String^ description
) |
Parameters
- MEPPartId
- Type: Autodesk.Revit.DB..::..ElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
- description
- Type: System..::..String
The description of the rule.
Exceptions
See Also