Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ExternalResourceLoadStatus LoadFrom( ExternalResourceReference desiredResourceReference, KeyBasedTreeEntriesLoadResults loadResults ) |
Visual Basic |
---|
Public Function LoadFrom ( _ desiredResourceReference As ExternalResourceReference, _ loadResults As KeyBasedTreeEntriesLoadResults _ ) As ExternalResourceLoadStatus |
Visual C++ |
---|
public: ExternalResourceLoadStatus LoadFrom( ExternalResourceReference^ desiredResourceReference, KeyBasedTreeEntriesLoadResults^ loadResults ) |
Parameters
- desiredResourceReference
- Type: Autodesk.Revit.DB..::..ExternalResourceReference
An external resource reference describing the source of the desired KeyBasedTreeEntry data.
- loadResults
- Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadResults
If provided, Revit will use this object to store any errors or warnings that were encountered.
This argument may be nullNothingnullptra null reference (Nothing in Visual Basic).
Return Value
Returns whether the operation succeeded or failed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. -or- The ExternalResourceReference (desiredResourceReference) is not in a format that is supported by its server. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction. |