Scale a profile of the form, by a specified origin and scale factor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void ScaleProfile(
int profileIndex,
double factor,
XYZ origin
) |
Visual Basic |
---|
Public Sub ScaleProfile ( _
profileIndex As Integer, _
factor As Double, _
origin As XYZ _
) |
Visual C++ |
---|
public:
void ScaleProfile(
int profileIndex,
double factor,
XYZ^ origin
) |
Parameters
- profileIndex
- Type: System..::..Int32
Index to specify the profile.
- factor
- Type: System..::..Double
The scale factor, it should be large than zero.
- origin
- Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.
See Also