A method called when the family was found in the target document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
bool OnFamilyFound( bool familyInUse, out bool overwriteParameterValues ) |
Visual Basic |
---|
Function OnFamilyFound ( _ familyInUse As Boolean, _ <OutAttribute> ByRef overwriteParameterValues As Boolean _ ) As Boolean |
Visual C++ |
---|
bool OnFamilyFound( bool familyInUse, [OutAttribute] bool% overwriteParameterValues ) |
Parameters
- familyInUse
- Type: System..::..Boolean
Indicates if one or more instances of the family is placed in the project.
- overwriteParameterValues
- Type: System..::..Boolean%
This determines whether or not to overwrite the parameter values of existing types. The default value is false.
Return Value
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.