Applies the input transform to this frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public void Transform(
	Transform trf
)
Visual Basic
Public Sub Transform ( _
	trf As Transform _
)
Visual C++
public:
void Transform(
	Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
The transform to apply to the frame.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException this operation failed.

See Also