Erases Schema and all its Entities from the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public void EraseSchemaAndAllEntities( Schema schema ) |
Visual Basic |
---|
Public Sub EraseSchemaAndAllEntities ( _ schema As Schema _ ) |
Visual C++ |
---|
public: void EraseSchemaAndAllEntities( Schema^ schema ) |
Parameters
- schema
- Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
The Schema to erase.
Remarks
The Schema remains in memory.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | No write access to this Schema. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |