Removes an existing parameter and creates a new binding for a given parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual bool ReInsert( Definition key, Binding item ) |
Visual Basic |
---|
Public Overridable Function ReInsert ( _ key As Definition, _ item As Binding _ ) As Boolean |
Visual C++ |
---|
public: virtual bool ReInsert( Definition^ key, Binding^ item ) |
Parameters
- key
- Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
- item
- Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
Remarks
Note the type of the binding object dictates whether the parameter is bound to all
instances or just types. A parameter definition cannot be bound to both instances and types.
If the parameter binding already exists, remove the binding, create a new parameter binding.