Tests that the given expression is a valid as formula for this parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public bool IsValidFormula( string expression ) |
Visual Basic |
---|
Public Function IsValidFormula ( _ expression As String _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidFormula( String^ expression ) |
Parameters
- expression
- Type: System..::..String
Remarks
Use this method to test validity of a formula before assigning it to a global
parameter when in doubt whether it is an acceptable expression or not.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |