Creates a solid by blending two closed curve loops lying in non-coincident planes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
Visual Basic |
---|
Public Shared Function CreateBlendGeometry ( _
firstLoop As CurveLoop, _
secondLoop As CurveLoop, _
vertexPairs As ICollection(Of VertexPair) _
) As Solid |
Parameters
- firstLoop
- Type: Autodesk.Revit.DB..::..CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
- secondLoop
- Type: Autodesk.Revit.DB..::..CurveLoop
The second curve loop, satisfying the same conditions as the first loop.
The planes of the first and second loops must not be coincident, but they need not be parallel.
- vertexPairs
- Type: System.Collections.Generic..::..ICollection<(Of <(<'VertexPair>)>)>
This input specifies how the two profile loops should be connected.
If null, the function chooses vertex connections that will result in a geometrically reasonable blend.
Return Value
The requested solid.
Exceptions
See Also