Checks if given type is valid flexible pipe type.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsFlexPipeTypeId( Document document, ElementId pipeTypeId ) |
Visual Basic |
---|
Public Shared Function IsFlexPipeTypeId ( _ document As Document, _ pipeTypeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsFlexPipeTypeId( Document^ document, ElementId^ pipeTypeId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- pipeTypeId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the flexible pipe type to check.
Return Value
True if flexible pipe type can used for this pipe, false otherwise.
Remarks
A type is valid for flexible pipe if it can be used to the flexible pipe element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |