Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool IsValidShape( IList<GeometryObject> shape ) |
Visual Basic |
---|
Public Function IsValidShape ( _ shape As IList(Of GeometryObject) _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidShape( IList<GeometryObject^>^ shape ) |
Parameters
- shape
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Return Value
True if the supplied shape passes the validation criteria.
Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |