Set the ElementId value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Set( FamilyParameter familyParameter, ElementId value ) |
Visual Basic |
---|
Public Sub Set ( _ familyParameter As FamilyParameter, _ value As ElementId _ ) |
Visual C++ |
---|
public: void Set( FamilyParameter^ familyParameter, ElementId^ value ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
A family parameter of the current type.
- value
- Type: Autodesk.Revit.DB..::..ElementId
The new value for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input ElementId is not valid as a value for this FamilyParameter. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid. |