Creates a new angular dimension object using the default dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Dimension NewAngularDimension( View view, Arc arc, Reference firstRef, Reference secondRef ) |
Visual Basic |
---|
Public Function NewAngularDimension ( _ view As View, _ arc As Arc, _ firstRef As Reference, _ secondRef As Reference _ ) As Dimension |
Visual C++ |
---|
public: Dimension^ NewAngularDimension( View^ view, Arc^ arc, Reference^ firstRef, Reference^ secondRef ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
- arc
- Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
- firstRef
- Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- secondRef
- Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
Return Value
If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.
Remarks
The currently user set default style is used for the created dimension.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed. |