Crates a new instance of a curve as a transformation of this curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public Curve CreateTransformed( Transform transform ) |
Visual Basic |
---|
Public Function CreateTransformed ( _ transform As Transform _ ) As Curve |
Visual C++ |
---|
public: Curve^ CreateTransformed( Transform^ transform ) |
Parameters
- transform
- Type: Autodesk.Revit.DB..::..Transform
The transform to apply.
Return Value
The new curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | transform is not conformal. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |