Dissolves a collection of form elements into their defining elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static ICollection<ElementId> DissolveForms( Document ADoc, ICollection<ElementId> elements, out ICollection<ElementId> BondingPointSet ) |
Visual Basic |
---|
Public Shared Function DissolveForms ( _ ADoc As Document, _ elements As ICollection(Of ElementId), _ <OutAttribute> ByRef BondingPointSet As ICollection(Of ElementId) _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: static ICollection<ElementId^>^ DissolveForms( Document^ ADoc, ICollection<ElementId^>^ elements, [OutAttribute] ICollection<ElementId^>^% BondingPointSet ) |
Parameters
- ADoc
- Type: Autodesk.Revit.DB..::..Document
The document
- elements
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
- BondingPointSet
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%
A collection of the point element ids called "bonding points" (see below for description of "bonding points")
Return Value
A collection of curve element ids from the profiles and paths of the dissolved forms.
Remarks
Bonding points define the workplane of form profiles and paths and their curves.
The bonding point represents a coordinate system with an origin (reference point) which
can be manipulated to move the curves of a profile together as a unit after dissolve.
Bonding points may themselves be constrained to other parts of the model or parts of the form,
based on how the form was created/constructed. This is done through the reference point hosting
mechanism.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The elements do not include Forms that can be dissolved. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |