Resets all manual adjustments performed by the user onto the Analytical Model.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool ResetManualAdjustment() |
Visual Basic |
---|
Public Function ResetManualAdjustment As Boolean |
Visual C++ |
---|
public: bool ResetManualAdjustment() |
Return Value
Indicates the successful reset of all manual adjustment. True if reset succeeds, false otherwise.
Remarks
Resets all manual adjustment. Therefore, if Analytical Offset is applicable,
that will reset as well.
Success, in this context, is achieved only when the Source resets itself to its original position.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment. |