Creates new analytical connections between the equipment connector and the nearest point on the curves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
Visual Basic |
---|
Public Shared Function CreateMultipleConnections ( _
doc As Document, _
typeId As ElementId, _
equipmentOpenConnectors As IList(Of Connector), _
curveIdsToConnect As IList(Of ElementId) _
) As ISet(Of ElementId) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document where the new elements are created.
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
The type of new analytical connections.
- equipmentOpenConnectors
- Type: System.Collections.Generic..::..IList<(Of <(<'Connector>)>)>
The open equipment connectors to be analytically connected.
- curveIdsToConnect
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The curves which the equipment is connected to.
Return Value
The new analytical connection elements.
Exceptions
See Also