Sets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public bool SetCategories(
	ICollection<ElementId> categories
)
Visual Basic
Public Function SetCategories ( _
	categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCategories(
	ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories.

Return Value

True if the set of categories was changed, false if no change was necessary.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One of the given categories is not filterable
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also