Gets the string used in type catalogs to identify a given unit type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForSpec(ForgeTypeId)` method instead.")]
public static string GetTypeCatalogString(
UnitType unitType
) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForSpec(ForgeTypeId)` method instead.")> _
Public Shared Function GetTypeCatalogString ( _
unitType As UnitType _
) As String |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForSpec(ForgeTypeId)` method instead.")]
public:
static String^ GetTypeCatalogString(
UnitType unitType
) |
Return Value
The type catalog string, or an empty string if the unit type cannot be used in type catalogs.
Exceptions
See Also