The location on the curve from which the measurement is taken.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public PointOnCurveMeasureFrom MeasureFrom { get; set; } |
Visual Basic |
---|
Public Property MeasureFrom As PointOnCurveMeasureFrom Get Set |
Visual C++ |
---|
public: property PointOnCurveMeasureFrom MeasureFrom { PointOnCurveMeasureFrom get (); void set (PointOnCurveMeasureFrom value); } |
Remarks
The measure-from is not checked until this class is assigned for a particular reference point on a particular curve.
At that time, the measure-from must be valid for the curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |