Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Form NewFormByThickenSingleSurface(
bool isSolid,
Form singleSurfaceForm,
XYZ thickenDir
) |
Visual Basic |
---|
Public Function NewFormByThickenSingleSurface ( _
isSolid As Boolean, _
singleSurfaceForm As Form, _
thickenDir As XYZ _
) As Form |
Visual C++ |
---|
public:
Form^ NewFormByThickenSingleSurface(
bool isSolid,
Form^ singleSurfaceForm,
XYZ^ thickenDir
) |
Parameters
- isSolid
- Type: System..::..Boolean
Indicates if the Form is Solid or Void.
- singleSurfaceForm
- Type: Autodesk.Revit.DB..::..Form
The single-surface form element. It can have one top/bottom face or one side face.
- thickenDir
- Type: Autodesk.Revit.DB..::..XYZ
The offset of capped solid.
Return Value
This function will modify the input singleSurfaceForm and return the same element.
See Also