Sets the projection type of the CurveElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void SetProjectionType( CurveElement curveElem, CurveProjectionType value ) |
Visual Basic |
---|
Public Shared Sub SetProjectionType ( _ curveElem As CurveElement, _ value As CurveProjectionType _ ) |
Visual C++ |
---|
public: static void SetProjectionType( CurveElement^ curveElem, CurveProjectionType value ) |
Parameters
- curveElem
- Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
- value
- Type: Autodesk.Revit.DB..::..CurveProjectionType
The input projection type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |