Identifies the hook tangent length for a hook type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetHookTangentLength( ElementId hookId, double newLength ) |
Visual Basic |
---|
Public Sub SetHookTangentLength ( _ hookId As ElementId, _ newLength As Double _ ) |
Visual C++ |
---|
public: void SetHookTangentLength( ElementId^ hookId, double newLength ) |
Parameters
- hookId
- Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
- newLength
- Type: System..::..Double
The hook tangent length for a hook type
Remarks
AutoCalcHookLengths is ignored when this property is set
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |