The position of the tag's head.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
Remarks
Returns the end point of the tag leader.
Leader end point must be located inside of a room, space or an area.
Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Head position of the tag with no leader could not be located outside of the host element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned. |