Implement this method to return the id of the server.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
Guid GetServerId() |
Visual Basic |
---|
Function GetServerId As Guid |
Visual C++ |
---|
Guid GetServerId() |
Return Value
The id of the server.
Remarks
The Id must uniquely identify the external server
to the corresponding external service. It will be
an error when two servers with identical Ids try
to register for one external service.