Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public ElementParameterFilter(
FilterRule filterRule,
bool inverted
) |
Visual Basic |
---|
Public Sub New ( _
filterRule As FilterRule, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
ElementParameterFilter(
FilterRule^ filterRule,
bool inverted
) |
Parameters
- filterRule
- Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.
- inverted
- Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rule.
Exceptions
See Also