Gets the user-visible name for a StructuralSectionShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static string GetStructuralSectionShapeName( StructuralSectionShape shape ) |
Visual Basic |
---|
Public Shared Function GetStructuralSectionShapeName ( _ shape As StructuralSectionShape _ ) As String |
Visual C++ |
---|
public: static String^ GetStructuralSectionShapeName( StructuralSectionShape shape ) |
Parameters
- shape
- Type: Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionShape
The StructuralSectionShape to get the user-visible name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |