Reports if rule needs to be executed on individual elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool WillRuleCheckElements( PerformanceAdviserRuleId id ) |
Visual Basic |
---|
Public Function WillRuleCheckElements ( _ id As PerformanceAdviserRuleId _ ) As Boolean |
Visual C++ |
---|
public: bool WillRuleCheckElements( PerformanceAdviserRuleId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.
Return Value
True if rule needs to be executed on individual elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |