Prompts the user to select elements to change them to the input type.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void PromptToMatchElementType( ElementType elementType ) |
Visual Basic |
---|
Public Sub PromptToMatchElementType ( _ elementType As ElementType _ ) |
Visual C++ |
---|
public: void PromptToMatchElementType( ElementType^ elementType ) |
Parameters
- elementType
- Type: Autodesk.Revit.DB..::..ElementType
The ElementType applied to selected instances.
Remarks
This method uses its own transaction, so it's not permitted to be invoked in an active transaction.
In a single invocation, the user can select multiple elements to be modified to the given type, until they finish.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This document is not the currently active one. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction. |