Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public IList<int> GetRegionsAlongLevel(
	double height
)
Visual Basic
Public Function GetRegionsAlongLevel ( _
	height As Double _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionsAlongLevel(
	double height
)

Parameters

height
Type: System..::..Double
Distance from the bottom of the wall.

Return Value

The ids of the regions intersected by the specified line.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The height is outside valid range. It should be in the range of [0, SampleHeight].

See Also