Shrinks the multistory stairs by disconnecting input levels.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void DisconnectLevels( ISet<ElementId> levelIds ) |
Visual Basic |
---|
Public Sub DisconnectLevels ( _ levelIds As ISet(Of ElementId) _ ) |
Visual C++ |
---|
public: void DisconnectLevels( ISet<ElementId^>^ levelIds ) |
Parameters
- levelIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The level ids.
Remarks
If you remove a stairs that is connected at the top and bottom to another level stairs, the remaining stairs will automatically adjust to maintain the multistory stairs.
The stairs above the one that is removed extends to attach to the stairs on the level below the one that is removed.
You cannot disconnect the levels of standard stair (the stair associated with the Reference Level for the multistory stairs) or already disconnected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This multistory stairs cannot disconnect from one or more members of levelIds. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |