Transforms this profile and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Profile this[ Transform transform ] { get; } |
Visual Basic |
---|
Public ReadOnly Property Transformed ( _ transform As Transform _ ) As Profile Get |
Visual C++ |
---|
public: property Profile^ Transformed[Transform^ transform] { Profile^ get (Transform^ transform); } |
Parameters
- transform
- Type: Autodesk.Revit.DB..::..Transform
The transformation used to transform the profile.
Return Value
The transformed profile.
Remarks
Transforms all the curves that define the boundary of this profile.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to transform a curve in the profile. |