Creates an Guid-based enum instance with the supplied name and GUID.
GUID-based enum instance can be compared by this guid value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public GuidEnum( Guid guid ) |
Visual Basic |
---|
Public Sub New ( _ guid As Guid _ ) |
Visual C++ |
---|
public: GuidEnum( Guid guid ) |
Parameters
- guid
- Type: System..::..Guid
The GUID of this GUID-based enum.