This value tells the exporter of 2D views to force the given display mode for the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public DisplayStyle Export2DForceDisplayStyle { get; set; } |
Visual Basic |
---|
Public Property Export2DForceDisplayStyle As DisplayStyle Get Set |
Visual C++ |
---|
public: property DisplayStyle Export2DForceDisplayStyle { DisplayStyle get (); void set (DisplayStyle value); } |
Remarks
Only DisplayStyle::Wireframe and DisplayStyle::HLR values are supported.
Default forced value is DisplayStyle::HLR unless the view has DisplayStyle:Wireframe.
See notes for 2D export for views in non-Wireframe display style in [!:Autodesk::Revit::DB::IExportContextBase] and IExportContext2D.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |