Get the total occupiable floor area represented by a mass instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static double GetGrossFloorArea( Document document, ElementId massInstanceId ) |
Visual Basic |
---|
Public Shared Function GetGrossFloorArea ( _ document As Document, _ massInstanceId As ElementId _ ) As Double |
Visual C++ |
---|
public: static double GetGrossFloorArea( Document^ document, ElementId^ massInstanceId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- massInstanceId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.
Return Value
The gross floor area in square feet.
Remarks
The area is computed from the cross sections that are created by intersecting the
associated Levels with the mass instance Geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |