Derived classes override this method to implement the test that determines
whether the two given double-precision values satisfy the desired condition or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool Evaluate( double lhs, double rhs, double epsilon ) |
Visual Basic |
---|
Public Function Evaluate ( _ lhs As Double, _ rhs As Double, _ epsilon As Double _ ) As Boolean |
Visual C++ |
---|
public: bool Evaluate( double lhs, double rhs, double epsilon ) |
Parameters
- lhs
- Type: System..::..Double
A value from an element in the document.
- rhs
- Type: System..::..Double
The user-supplied value against which values from the document are tested.
- epsilon
- Type: System..::..Double
Defines the tolerance within which two values may be considered equal.
Return Value
True if the given arguments satisfy the condition, otherwise false.
Remarks
The arguments may be thought of as the left and right operands of a
binary expression; for example, "a < b", "x >= 100", etc. The left
operand comes from an element in the Revit document (e.g., the value
of a parameter.) The right operand is supplied by the user when
creating the filter that contains the rule that uses this evaluator.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for lhs is not finite -or- The given value for lhs is not a number -or- The given value for rhs is not finite -or- The given value for rhs is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |