Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarFreeFormValidationResult SetCurves( IList<IList<Curve>> curves ) |
Visual Basic |
---|
Public Function SetCurves ( _ curves As IList(Of IList(Of Curve)) _ ) As RebarFreeFormValidationResult |
Visual C++ |
---|
public: RebarFreeFormValidationResult SetCurves( IList<IList<Curve^>^>^ curves ) |
Parameters
- curves
- Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'Curve>)>)>>)>)>
Each array of curves represent a bar in the set.
Return Value
Returns Success(0) if everything is ok, otherwise the failure reason.
Remarks
This function can fail due to following reasons:
- One or more of the input curves was null.
- One or more of the input curves was unbounded.
- Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarFreeFormAccessor Rebar is constrained. |