Check that joins in the physical model are consistent
with proximity in the analytical model.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool AnalyticalModelCheckSupportDistance { get; set; } |
Visual Basic |
---|
Public Property AnalyticalModelCheckSupportDistance As Boolean Get Set |
Visual C++ |
---|
public: property bool AnalyticalModelCheckSupportDistance { bool get (); void set (bool value); } |
Remarks
When this check is enabled, a warning will be given
for physically joined members whose analytical curves are
more than a certain distance apart. The distance is given
by the AnalyticalModelSupportDistanceTolerance property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |