remove a set of exist components from the Electrical System.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void RemoveFromCircuit( ElementSet components ) |
Visual Basic |
---|
Public Sub RemoveFromCircuit ( _ components As ElementSet _ ) |
Visual C++ |
---|
public: void RemoveFromCircuit( ElementSet^ components ) |
Parameters
- components
- Type: Autodesk.Revit.DB..::..ElementSet
The components removed from the electrical system.
Remarks
If successful, all the components will remove from the system. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is removed.
This method will only function with the Autodesk Revit MEP application.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the components parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the components cannot be removed from the system. |