Compute the driving curves.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public IList<Curve> ComputeDrivingCurves() |
Visual Basic |
---|
Public Function ComputeDrivingCurves As IList(Of Curve) |
Visual C++ |
---|
public: IList<Curve^>^ ComputeDrivingCurves() |
Return Value
Returns an empty array if an error is encountered.
Remarks
The driving curves are the ones that appear in rebar sketch
mode. They include lines and arcs that drive the shape, but
exclude fillets and hooks. They always lie in a plane--
if the bar is 3D, these curves are a subset or a projection.
They are also used for shape matching.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |