Gets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public IList<LinePatternSegment> GetSegments()
Visual Basic
Public Function GetSegments As IList(Of LinePatternSegment)
Visual C++
public:
IList<LinePatternSegment^>^ GetSegments()

Return Value

The sequence of segments.

See Also